Thursday, July 11, 2013

Router troubles #Lesson 1 : Check the splitter and cables first

Since the past 3 days, the green 'internet' light on my Buffalo router has stopped glowing, and I have lived in an internet-less hell hole. 

Troubleshooting proved to be in vain. The Buffalo router showed me the message 'internet cable not connected' but also helpfully added that 'any information may be displayed if your internet is down'. As this has proven to be true in the past, and all cables were securely connected, I ignored this message. It was easier to blame MTNL, especially with the stormy monsoon weather, for a cable fault. But I was not quite at ease doing this. I know from experience that the internet light fault usually reflects a hardware failure or hardware conflict at the user end, though it may also be that the DNS server is down. But this is a temporary issue and it certainly should not continue for a full day.

I googled for answers only to find that the world is full of frustrated router users like me looking for answers in a maze. PC problems are relatively easy to troubleshoot as in most cases they are software based. Router and network-related problems are way  more specific and harder to solve since hardware interfaces are involved in addition to software. Here, the rule is to check and eliminate hardware issues first.

Finally I got a clue from some exasperated users in a Sky TV UK forum (the posts were at least 4 years old). The moderator advised the users to  check the 'splitter' which routes the DSL connection to the modem. On an off chance, I did the same. If you have a phone+broadband connection, you would also have the splitter, a cheap plastic device which splits the MTNL line so you can plug the cable into your phone and modem.



I changed the splitter, as a last resort. And immediately, the internet started working, perfectly.

A big lesson - before you go into forums, start changing DNS server settings on your modem or blaming your ISP (all of which I did), check the basics. Cabling problem need not be caused by a loose cable, it could be a faulty junction point. And keep a couple of splitters handy at home. You never know when you might need them!